Service Unavailability - UA2.IEV/UA1.HRK Wednesday 23rd September 2026


UPDATE 3 (21:50 EEST):

There is still no estimated time for restoring services at our UA1/UA2 locations.

Emergency and goverment services continue to work on site, but we have not yet received any official updates.

We will share further information as soon as it becomes available. Thank you for your patience and understanding.


UPDATE 2 (13:00 EEST):

According to preliminary reports from datacenter staff, the equipment appears to be undamaged. However, we do not yet have an estimated time for bringing it back online and restoring services. As soon as further information becomes available, we will publish an update on our Status Page.


UPDATE (12:00 EEST):

Infrastructure components at our UA2.IEV location in Kyiv have been powered off following a russian attack in the area. The condition of these components and the overall status of the location remain unclear. There is still no estimated time for service restoration.

We recommend that affected customers review their disaster recovery plans. Replacement VDS and Dedicated Servers are available for immediate activation at our EU and US locations. Please contact our support team through the customer portal for details and to arrange replacement.

We appreciate your patience and support. Updates will be posted on our status page.


Our UA2.IEV location in Kyiv has been unavailable since 11:10 EEST (08:10 UTC) on September 23. There is currently no estimated time for service restoration.

More details and updates will be posted on our status page. If you have any questions, please contact our support team through the customer portal.