EU1.AMS MEP Datacenter Power Feed Issue Monday 28th April 2025


We investigating connectivity issue between our EU1.AMS datacenters. More information will be posted soon.

Power has been stabilized at the Serverius NL2 Meppel facility. All systems now appear to be operational or in the process of booting up.

Our teams are carefully checking all services to ensure full functionality and stability. We will continue to monitor the situation closely and provide further updates if needed.

Thank you for your continued patience and support.

Power has been restored to most systems at the Serverius NL2 Meppel facility. However, Power Feed B is not yet fully stable, and a small number of racks and services may still experience unavailability. On-site engineering teams, in cooperation with data center technicians, are actively working to stabilize Power Feed B and restore full service as soon as possible. We will continue to provide updates as more information becomes available. Thank you for your understanding and patience.

The power outage at the Serverius NL2 Meppel facility has been resolved partially. The vast majority of services are now operational. A small number of services remain unavailable, and our data center technicians are actively working to restore full functionality as quickly as possible. We appreciate your patience and support during this incident. A detailed Reason for Outage (RFO) will be provided once final investigations are completed.

Investigation is still in progress regarding the power outage at our NL2, Meppel location. Affected systems include those dependent on Power Feed A and B. Full restoration efforts are ongoing in cooperation with on-site engineers. We sincerely appreciate your continued patience. A full Reason for Outage (RFO) will be provided after resolution.

Update: the issue is still under investigation, Power Feed A and B are affected at the Serverius NL2 facility.

Update: the issue is still under investigation, Power Feed A and B are affected at the Serverius NL2 facility.

Update from datacenter staff: "There is currently an issue affecting Power Feed A at the Serverius NL2 facility. Our Support and Facility teams are actively investigating and working to resolve the problem as quickly as possible. We will keep you updated on our progress and provide a detailed Reason for Outage (RFO) once the issue has been resolved. Thank you for your understanding and patience."

ETA: To be determined

Situation update - We are experiencing partial network unavailability in one of our data centers in the Netherlands. Our engineers are currently investigating this issue.